Special Offer

yMail2
by Spacejock Software
WinXP & above / Mono 2.4 & above


yMail2 will not yet run on Linux/OSX



yMail2 still needs tweaking to run on Wine.